Skip to content

Instantly share code, notes, and snippets.

#!/usr/bin/env bash
# Author: remontti.com.br
# Define color codes with standard ANSI escape sequences
GREEN='\033[1;32m'
BLUE='\033[1;36m'
YELLOW='\033[1;33m'
NC='\033[0m'
#!/bin/bash
# Autor: remontti.com.br
VERDE='\033[1;32m'
AZUL='\033[1;36m'
AMARELO='\033[1;33m'
NC='\033[0m'
echo " ${AZUL} .,,, ./##( ${NC}";
echo " ${AZUL} *%&%(. .,,,/@&&(. ${NC}";
echo " ${AZUL} , #%###%&@@@* ,,,,,,,,,,,,,,, .,. ${NC}";
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="specialize">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<ComputerName>PC-USER</ComputerName>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
@elico
elico / mtcna.md
Created March 22, 2025 23:44
# MikroTik Certified Network Associate (MTCNA) - Training Outline

MikroTik Certified Network Associate (MTCNA) - Training Outline

Last edited: November 18, 2019


Duration

  • 3 days

Outcomes

/system routerboard settings set boot-device=try-ethernet-once-then-nand;
execute script={/system reboot }
{
:local gotifyToken "testToken";
:local gotifyEndpointUrl "https://gotify.example.org/mesasge";
:local serviceName "web service";
:local source "Device 1234";
:local state "TEST";
:local state "DOWN";
:local state "UP";
<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>MikroTik Port Forward Generator</title>
<style>
body {
font-family: Arial, sans-serif;
margin: 20px;
$outDir = ".\out\"
$sourceDir = ".\in\"
$historyDir = ".\history\"
$workDir = ".\working\"
$imageFile = "michael.png"
$inputFormat = "mp3"
$outputFormat = "mp4"
mkdir "$sourceDir" -Force
mkdir "$outDir" -Force
#!/usr/bin/env bash
IP_LIST_FILE="ips"
KEYS_FILE="keys.txt"
SSH_PASS="$(head -1 ssh_password)"
SSH_USER="root"
SSH_PORT="22"
{
:local snmpAddressesString "";
:local snmpAddressesComparisonString "";
:local addressLists {"LIST1"; "LIST2"}
:local community "public";
:local currentSnmpAddresses [/snmp/community/get [find where name=$community] addresses];
:foreach addressListName in=$addressLists do={
foreach i in=[/ip/firewall/address-list/find where list="$addressListName"] do={
:local ipAddress [/ip/firewall/address-list/get number=$i address];
:if ( $ipAddress~"^[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\$" ) do={