- Serial Port: /dev/cu.SLAB_USBtoUART
- Baud Rate: 115200
- Data Bits: Eight
- Stop Bits: Two
- Handshake: None
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# Default configuration IPv6 firewall rules. | |
# | |
# Extracted from RouterOS 6.46.4 with: | |
# /system default-configuration print | |
/ipv6 firewall address-list | |
add address=::/128 comment="defconf: unspecified address" list=bad_ipv6 | |
add address=::1/128 comment="defconf: lo" list=bad_ipv6 | |
add address=fec0::/10 comment="defconf: site-local" list=bad_ipv6 | |
add address=::ffff:0.0.0.0/96 comment="defconf: ipv4-mapped" list=bad_ipv6 |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# Dutch ISP Tweak offers IPv6 via 6rd. The commands below configure a mikrotik | |
# RouterOS with 6rd. This was tested with RouterOS 6.46.1. | |
# | |
# First, you'll have to request IPv6 information from Tweak. You'll receive | |
# a fixed IPv4 address and some other information. For the rest of this guide, | |
# I assume the following information is received from Tweak: | |
# | |
# === | |
# IPv4 address: 185.227.123.123 | |
# IPv4 mask length: 22 |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# 1. update your aws cli | |
# https://docs.aws.amazon.com/cli/latest/userguide/cli-chap-install.html | |
# | |
# 2. update your existing cluster with capacity providers support | |
CLUSTER_NAME=fargate | |
SERVICE_NAME=myservice | |
FARGATE_WEIGHT=1 | |
FARGATE_SPOT_WEIGHT=1 | |
FARGATE_BASE=1 | |
FARGATE_SPOT_BASE=0 |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# syntax = docker/dockerfile:1.0-experimental | |
FROM python:3.7-alpine AS builder | |
WORKDIR /app | |
COPY . . | |
# mount the secret in the correct location, then run pip install | |
RUN --mount=type=secret,id=pipconfig,dst=/etc/pip.conf \ | |
pip install -r requirements.txt |
In this scenario we are going to set up Vault to sign SSH keys using an internal CA. We will configure the SSH secrets engine and create a CA within Vault. We will then configure an SSH server to trust the CA key we just created. Finally we will attempt to SSH using a private key, and a public key signed by Vault SSH CA.
- This guide assumes you have already provisioned a Vault server, SSH host using OpenSSH server, and a SSH client machine.
- The client system must be able to reach the Vault server and the OpenSSH server.
- We will refer to these systems respectively as:
- VAULT_SERVER
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
import boto3 | |
from boto3.session import Session | |
def assume_role(arn, session_name): | |
"""aws sts assume-role --role-arn arn:aws:iam::00000000000000:role/example-role --role-session-name example-role""" | |
client = boto3.client('sts') | |
account_id = client.get_caller_identity()["Account"] | |
print(account_id) |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
package main | |
import ( | |
"encoding/json" | |
"fmt" | |
"net/http" | |
"time" | |
"github.com/hashicorp/vault/api" | |
"github.com/hashicorp/vault/builtin/credential/aws" |
Documenting this here, as I often forget (what I have found) is the best way to do this at the moment.
For example, you have a list of two existing security groups given to a stack and wish to create (and use) a third - attaching all to an ALB:
AWSTemplateFormatVersion: '2010-09-09'
Description: Example template
NewerOlder